Wisnode-Lora



  • 0_1500304473054_IMG_20170717_171110.jpg

    Forgot to mention, but as you can see, i've also bent the reset pin to rule that problem out.



  • I have exactly the same issue. The test program 0_1499065917806_testUart.ino responds properly. When I try to use the LoRaP2PPingPongTest I see the commands sent but never get back a response. I have the shift boards installed, they sent them to me after I ordered. I have bent the reset pin out of the way.



  • @meldundas @Twenyong

    I have run the 1499065986265-testuart program. After I sent a string in the arduino serial monitor ('at+join=otaa', of which i know the answer should be: 'at+recv=6,0,0') I got 'at+version' back.

    Looking at the source this makes sense: the string you put in the serial monitor is sent to the SoftwareSerial (10/11), but then the program tells to print 'at+version' to the hardware serial port. Any answer from the Wisnode is not displayed on the Serial Monitor in this way, but the commands you give should arrive at the Wisnode.

    I don't know what the purpose of the program was? Send at+version to the SoftwareSerial?

    The original is found here:
    https://www.arduino.cc/en/Reference/SoftwareSerialExample

    If you run this code (change the pins and baud rate to your own setup), Serial Monitor strings are sent, and replies are received from the Wisnode (again, if it would answer).



  • It took some hours, mainly because I am kind of new with a lot of this ;-)
    I connected the arduino (with voltage divider!) direct to TXD and RXD on the wisnode. After some probing, i found that commands are passed from the wisnode USB to these ports, so communication should work.

    Still no answer.

    The main problem was this: Arduino Serial.write does not write a carriage return.
    When the wisnode does not receive a carriage return, it does not execute the command.

    add this line on top of the SoftwareSerialExample i linked in my previous post:

    char carriageCheck;

    change the bottom few lines so it is as follows:

    0_1500390604984_carriagecheck.PNG

    If i bodged this together correctly (i haven't tested it extensively ;-)) it should check for the end of the text, and replace it with \r\n, also it adds a local echo of your command.

    It will start with Error -1 because 'carriageCheck' is still empty, but after that no problems.

    Results:

    0_1500390646799_arduinowisnode.PNG



  • @laef Hi lafe,Why do you connect the wires like this? you're using our latest version of the development board,You only need to move the top of the jump cap below to achieve the Serial level 3.3V to 5V;Please remove components C14 and C13;
    0_1500549915065_图片1.png
    0_1500550140923_QQ截图20170720192652.jpg



  • @Twenyong
    Thanx for that info, I already suspected I had another revision, but could not find out what the exact differences are.
    Are these changes documented somewhere?

    Now that i have achieved communication between the arduino and wisnode, i run into a different problem:

    when i send at+join=otaa through USB, i see the TX and RX leds (LED2/LED3) show activity.
    when i send at+join=otaa through arduino, i see no activity of TX/RX leds, although the answer of the module is exactly the same (OK and after a few seconds at+recv=6,0,0. I have no coverage so that's expected)

    First i will try the above changes and use the module with 5V, that rules out that the voltage divider is in some way interfering..



  • Join command from arduino.
    * No LED2, LED3 activity.
    * not able to join networks, even when i should be in range.

    Join command from onboard USB/CH340G
    * LED2, LED3 both show activity
    * not tested yet if i am able to join networks this way, did not have it on the road yet with usb->serial console.

    In both cases, response is the same:
    OK
    at+recv 6,0,0

    Why is the behaviour of LEDs different? Why can I send commands, receive 'OK' but not able to communicate with LoraWAN when i'm using arduino serial port?

    Never mind. I see in the schematic that LED2 and LED3 are the CH340G TX/RX leds.



  • @Twenyong thanks for the info.
    Can we just mount the Wisnode shield on an Arduino Uno?
    Can you provide a sample sketch?

    EDIT: oh, looked past the 1499065986265 ino link. Will try this.



  • @laef @Twenyong

    Hey guys, did you ever get the Wisnode working? My setup is the Wisnode shield on top of an Arduino Uno.
    Wisnode jumpers like this BOOT+GND, 5_3R+TXD, 5_3T+RXD. The boards are powered via the Uno usb port.
    The 1499065986265 sketch returns nothing in the Arduino serial monitor, both 9600 & 115200.
    The wisnode board worked fine before, when I followed the tutorial to connect it with TTN. I used Realterm for the AT commands.

    Any thoughts?



  • @dale_cooper i never got mine working with an arduino uno either (also tried arduino mega, no luck) i just bought a device like the microchip RN2483, which has MUCH better support than RAK


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.