RAK5205 - Node only send confirmed messages [solved]

  • I have upgraded my RAK5205 node to the latest firmware available (RAK5205_TrackerBoard software version:

    But now, the node is only sending confirmed messages.

    I have tried changing the settings wit the command: at+msg_confirm:0

    RAK5205_TrackerBoard software version:
    LIS3DH init success!
    ACC X:-240mg Y:-32mg Z:-912mg
    BME680 init success!
    T: 40.02 degC, P: 1028.86 hPa, H 18.02 %rH , G: 17289 ohms
    Please Configurate parameters...
    Configuration OK!
    app_interval = 10
    gps_stime = 60
    msg_confirm = 0
    power_save = 0
    Selected LoraWAN 1.0.2 Region: EU868
    Board Initialization OK!

    The messages received in the TTN console indicates that they are confirmed messages

    0_1546077217192_Screenshot from 2018-12-29 10-53-07.png

    I have tried to change the msg_confirm setting to 1, but they are also confirmed messages. If I revert the setting back to 0, they are still confirmed messages

    If I manually send a message wit the following command:
    I can see on the TTN console that the message is an unconfirmed message

  • Could you please provide the binary of the 1.6 firmware so the node is not sending confirmed messages continuously which rapidly violates the TTN fair use policy.

    It would also a good idea to provide the configuration to rebuild the firmware without having to use expensive software like Keil uvision.

  • Hi,thanks for your test,and you're right.The "at+msg_confirm"command was indeed invalid,we have modify the bug,and you could test it again with the latest firmware :RAK5205_TrackerBoard firmware

  • Thank you Leopold,
    I have upgraded the firmware and I am now able to send unconfirmed messages.

    Please note that this new firmware release is returning the same firmware version as the previous one: "RAK5205_TrackerBoard software version:"

    It means that you have in the field, different versions of this firmware returning the same firmware version.

Log in to reply

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.