New Serious Problems with RAK811



  • We recently used RAK811 module in some sensor nodes and it should send data twice a day. It's clear that we operate RAK811 in class A. After these tests, we found many problems in RAK811 operation that would make it useless.
    *1:In OTAA join to network, module "always" use SF7 to join network which is not true, refer to LoRaWAN Specifications. It would be better to use SF 12 to have a more "reliable Join".
    *2:Module should optimize it's "Data Rate" after join response! It's part of LoRaWAN Spec. and module just use SF 12 with its last firmware V2030.
    *3:Some times after exit from Sleep mode, Module will not send any data. It receives command to send data whether with or without ack, then response with "OK", but "at+recv=1,0,0" response with appear about 1-3 minutes later!!! We don't know what is the problem. This is the most important problem, because it will increase power consumption significantly.
    *4:Other problem is about "AT Command" interface. It's better to receive a response like "Busy" when it's LoRaMAC is trying to do something like join or send. For now, user will not know the situation and cannot do anything else but waiting for response.
    We are studying RAK811 to find other possible problems, but it will be greatly appreciated if RAKWireless support team release a new firmware to solve this problems.



  • hi @Mojtaba-Zare can you give us the link of your firmware?



  • Hi @carlos-soria
    Sure, I'm using the latest firmware (firmware V2.0.3.0) from RAK github.
    below is the link of firmware:
    https://github.com/RAKWireless/RAK811/tree/master/AT Firmware



  • Hi @carlos-soria
    would you please tell me about your plan for these problems?
    Are you going to release a new Firmware? or we should start to develop our Firmware?



  • @Mojtaba-Zare
    Hi, i'm sorry for it, but the firmware you used is an old one, maybe you can try to use the newest firmware for RAK811.
    https://github.com/RAKWireless/RAK811_LoRaNode



  • HI @Mojtaba-Zare sorry about the late response.
    1* youre on the right; the best SF for join is sf12; it is not working on rak811.
    2* Data rate adaptive is optional, you can enable or disable with this commands:
    at+set_config=adr:off
    at+set_config=adr:on
    PS: ADR its suggestion for non-mobile devices, take it in count.
    3This is possible when you dont configure the channels correctly; please use the correct mask for you lorawan network.
    4
    youre on the right again, it must be a "busy" response.

    I can comment other things about rak811; in version 2.0.3.0 is not working the command: at+set_config=pwr_level:x. I don`t see any variation on the power consumption of the node. @fomi you can check this?



  • @carlos.soria @Mojtaba-Zare Yes,you're right about the command: at+set_config=pwr_level:x.This is a terrible bug .You should modify "mibReq.Type = MIB_CHANNELS_DEFAULT_TX_POWER;" to "mibReq.Type = MIB_CHANNELS_TX_POWER; "on lines 681 of the file "lora_config.c".The newest project link : RAK811_LoRaNode
    In addition,thanks for your 4 suggestions, We have noticed the problem you mentioned and have started to upgrade the firmware. Please keep an eye on our github update .



  • hi @leopold ! great response from RAKWireless, i am testing the new firmware; the power level condition now is working!
    thanks!


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.