EVK-RAK833 USB Problem with Raspberry Pi



  • I try to create a TTN gateway by using EVK-833 and RPi 3 B+. I want to use USB interface. I followed up this github repo but didn't get successful ttn connected gateway yet. This is my error message:

    *** Beacon Packet Forwarder for Lora Gateway ***
    Version: 4.0.1
    *** Lora concentrator HAL library version info ***
    Version: 5.0.1;
    ***
    INFO: Little endian host
    INFO: found global configuration file global_conf.json, parsing it
    INFO: global_conf.json does contain a JSON object named SX1301_conf, parsing SX1301 parameters
    INFO: lorawan_public 1, clksrc 1
    INFO: LBT is disabled
    INFO: antenna_gain 0 dBi
    INFO: Configuring TX LUT with 16 indexes
    INFO: radio 0 enabled (type SX1257), center frequency 867500000, RSSI offset -166.000000, tx enabled 1, tx_notch_freq 129000
    INFO: radio 1 enabled (type SX1257), center frequency 868500000, RSSI offset -166.000000, tx enabled 0, tx_notch_freq 0
    INFO: Lora multi-SF channel 0>  radio 1, IF -400000 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora multi-SF channel 1>  radio 1, IF -200000 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora multi-SF channel 2>  radio 1, IF 0 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora multi-SF channel 3>  radio 0, IF -400000 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora multi-SF channel 4>  radio 0, IF -200000 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora multi-SF channel 5>  radio 0, IF 0 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora multi-SF channel 6>  radio 0, IF 200000 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora multi-SF channel 7>  radio 0, IF 400000 Hz, 125 kHz bw, SF 7 to 12
    INFO: Lora std channel> radio 1, IF -200000 Hz, 250000 Hz bw, SF 7
    INFO: FSK channel> radio 1, IF 300000 Hz, 125000 Hz bw, 50000 bps datarate
    INFO: global_conf.json does contain a JSON object named gateway_conf, parsing gateway parameters
    INFO: gateway MAC address is configured to B827EBFFFECF570B
    INFO: server hostname or IP address is configured to "router.eu.thethings.network"
    INFO: upstream port is configured to "1680"
    INFO: downstream port is configured to "1680"
    INFO: downstream keep-alive interval is configured to 10 seconds
    INFO: statistics display interval is configured to 30 seconds
    INFO: upstream PUSH_DATA time-out is configured to 100 ms
    INFO: packets received with a valid CRC will be forwarded
    INFO: packets received with a CRC error will NOT be forwarded
    INFO: packets received with no CRC will NOT be forwarded
    INFO: found local configuration file local_conf.json, parsing it
    INFO: redefined parameters will overwrite global parameters
    INFO: local_conf.json does not contain a JSON object named SX1301_conf
    INFO: local_conf.json does contain a JSON object named gateway_conf, parsing gateway parameters
    INFO: gateway MAC address is configured to B827EBFFFECF570B
    INFO: server hostname or IP address is configured to "router.eu.thethings.network"
    INFO: upstream port is configured to "1700"
    INFO: downstream port is configured to "1700"
    INFO: packets received with a valid CRC will be forwarded
    INFO: packets received with a CRC error will NOT be forwarded
    INFO: packets received with no CRC will NOT be forwarded
    INFO: Reference latitude is configured to 0.000000 deg
    INFO: Reference longitude is configured to 0.000000 deg
    INFO: Reference altitude is configured to 0 meters
    ERROR: [main] failed to start the concentrator
    

    I think that the problem may cause my 12 pin jumper combination. There is no clear description image of configuration jumper combination for using USB interface with RPi.

    Is there any idea?



Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.