Lorawan starter kit RAK 831 AS 923

  • Hi ,

    We had recently purchased the LoRaWAN starter kit, and have few doubts concerning the kit we received.

    1. We had ordered AS 923 version, however in kit we received the RAK 831 module shows 2 versions AS 923 and AS 915 (see attached photos). So which version is it ? Also the antennas are labelled 915 and not 923 Mhz ( see attached photo)

    Could you please let know what frequency band is the purcahsed RAK831 module and antenna compatible with?

    1. We tried testing gateway 831 and 811 wisnode on TTN, and wisnode gives error when sending data, although both get configured correctly. we tried flashing different binaries AS923, EU868, AU915 on Wisnode 811 but gives error when sending data. So curious if its because of mismatch of version/frequency band, as gateway 831 uses ic880 installer (which is only for 868 and 915 and not 923)

             We have used the user documentation on RAK website and also referenced the “getting started     guide....” on hackster.io as recommended.   

    ![2_1542795898927_P_20181121_171110.jpg](Uploading 100%) ![1_1542795898926_P_20181121_170950.jpg](Uploading 100%) ![0_1542795898925_P_20181121_170924.jpg](Uploading 100%)

  • Hi,
    I can't see the pictures, can you upload them again?

  • ![2_1542958812579_P_20181121_171110.jpg](Uploading 100%) ![1_1542958812579_P_20181121_170950.jpg](Uploading 100%) ![0_1542958812579_P_20181121_170924.jpg](Uploading 100%)

    Hi I upload the images using "upload images" icon, although to me too it just shows above text. Also attached as file below, its same.

    ![2_1542958903950_P_20181121_171110.jpg](Uploading 100%) ![1_1542958903950_P_20181121_170950.jpg](Uploading 100%) ![0_1542958903950_P_20181121_170924.jpg](Uploading 100%)

    Are you able to see else let me know how can I upload. I have also attached as ZIP here. 0_1542959048373_Pictures.zip

  • Hi,
    I've confirmed that these two hardwares are same, these hardwares, including antennas, can support 923 and 915.

    About the question 2, you may need our open source projects for RAK831 and RAK811.

  • Hi Fomi, thanks. look forward to using 923 antennas. I had another query.
    The RAK811 GPS tracker that came with starter kit, gives on error on flashing or when updated to newer version. The current version is 1.0.2. Using the STM flasher. Error: Cannot erase. Also the green led has stopped flashing when you plug in. Earlier when simply plugged out of the box , the red and green led use to flash. I was also able to see data using Realterm. Now cannot see any data, neither can flash. I want to change its freq to 923 Mhz, as its pre-configured to 868 Mhz. I have not installed/flashed anything yet. Just been observing data out-of-box and now its stopped working. Can you suggest anything that I can try.

  • Also the gateway when using GPS, does not give time or co-ordinates. I get GPRMC messages on my /dev/ttyS0, but without any co-ordinates. Also the UTC time shows from epoch. I have followed all recos from forum, but yet cannot get GPS for time sync or its co-ordinates. Using Poly_forwarder.

  • Hi,
    About GPS, we'll update the source code to support GPS tomorrow.

  • @fomi Thanks. We got the the GPS data (Co-ordinates & time) for gateway. Apparently after changing back to port AMA0 and also adding line in config text to disable BT. (Earlier just changed settings for serial in raspi-config, probably it requires full UART as suggested in forum) But probably what got it working, was simply to put the receiver under open sky ( also suggested in a forum, sitting next to big window doesnt work). So gateway is working fine. Now the tracker. Just fails to show any data, like it used to out-of-box . Even the green led which used to flash earlier on power-on does'nt flash anymore when connected to PC USB ? Earlier was able to see data using RealTerm and now it just stopped. Cannot flash either. Any suggestions ?
    0_1544076001145_tracker.zip Attaching photos of error ? I have tried reseting a few times, changed USB cables, jumpers as required BOOT0 to VCC, but the flasher gives Error, neither on Realterm. is tracker malfunctioned ?

    Occasionally, the flash error is not there, but cannot flash. See attached photo.0_1544081151124_flash error.zip Also included is the screenshot, first time connected via USB using RealTerm. After that it has just stopping responding.

  • @ssarda Hi,
    I have seed your attaching photos of error,and connect is no problem.Maybe when you reloading firmware with STMFlashLoader Demo.exe, the serial port is occupied by RealTerm or other software.Close other software with the serial port and retry.
    About the flasher erase error ,it is protected in STMFlashLoader Demo.exe.Means that it cannot erase all chip as follow 1 picture.But you can erase it by 2 picture,and after erased reload the firmware like picture 3.
    0_1544093644850_Picture1.png 0_1544093650204_Picture2.png 0_1544093655513_Picture3.png

  • @leopold Hi. Yeah I also had tried removing all software including RealTerm and closing all ports and then try. It still used to give error. I also wondered about erasing all, but was not sure if it would erase some required files not included in the upgrade. I will try erasing as you have mentioned and I ll update you. Mean time could you tell me why the GREEN LED, stopped flashing on power - on ?

  • @leopold Hi, Still gives flash error. I tried erasing using method 1 and method 2. For method 2, it gives a different error message. " Device is read protected".
    I tried multiple times, but same result. Also the "Flash Loader Demonstrator" does'nt read the device at first attempt. Have to keep on trying, till it reads the device and goes to the next screen i.e " Target device readable". See attached file for screenshot of error. 0_1544109293830_flash error 2.zip . To reconfirm my steps 1) Jumper connected to VCC C 2) Antennas connected 3 ) no other devices connected or software open ( no conflict) . Using Windows 10 Pro. Other devices (Wisnode 811, 831 ) work correctly and also able detect and flash.

  • 0_1544166638379_config.zip @ssardaHi, I found your picture of error is about read protected.you could try to configure the options in STMFlashLoader Demo.exe Followin the picture below ,you'd better after press reset key on the board and configure it every attempt configuration .0_1544166675251_config.zip 0_1544166689378_config.png

  • @leopold I disabled write protection as you mentioned. Then tried few times to flash it doesnt work. I also tried few times to erase using method 1 and method 2 doesnt work. Only once it was able to successfully erase using method 2 , but then cannot flash binary. Same errors. Please see attached photos0_1544178327896_flash error 3.zip

  • @leopold @fomi Could you also comment/feedback on the GREEN LED ,thats stopped flashing . It supposed to flash when board is power-on. I have mentioned this few times , but hav'nt received any comments on it.

  • @ssarda We have test many times,there's a situation more like your occur error.You could try that out.If that can't handle errors yet ,please detailed error steps to demonstrate that we can help you analyze and deal with the problem.

  • @ssarda About the GREEN LED:After normal startup,when automatic join OTAA the GREEN LED is flashing.Join Successed or Failed the GREEN LED stopped flashing. the RED LED indicate charging battery , the BLUE LED indicate send data by LoRa module. Your occured error feel like cannot normally flash firmware.

  • @leopold Thanks. Tried your suggestions. Tried multiple times. Same result. One of my attempts, it did erase data, but then it could not download data to chip. See error : Fail: Failed to download. 0_1544519963619_flash error 4.zip

  • @leopold When we opened and used the GPS tracker for first few times, the GREEN LED was always flashing. never stopped. And now it doesnt flash at all, since it still run the same code that device was shipped with, it shouldnt have stopped flashing ? From your description, Green LED should be flashing on turning on tracker, but it doesnt.

  • @ssarda Could you please send the screenshot of detailed operation steps together with the firmware? I will test your firmware and operation with your steps, and then help you analyze the reasons.

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.