Program RAK811 microcontroller (LoRaMac)



  • @fomi thanks for reply fomi, I have a question. I want the code not for AT command, but for ClassA automatic operation. Is the code you preferred different from this one ?
    Moreover, I programmed the code you suggested, but when I want to send it an string through serial connection, I receive "The Hard Fault exception occurs,Reset!". I don't know why?



  • @msadeghz Hi,
    Maybe you use the firmware at US915 region,and with used "at+ch_list" command , received "The Hard Fault exception occurs,Reset!" . Because It occurs stack overflow exception.This is a bug, and you could reload latest firmware at:https://github.com/RAKWireless/RAK811_LoRaNode/tree/master/doc .You also could modify the size of config_buf[] array from 1024 to 2048 in the source code "lora_config.c ".



  • thank you Leopold,
    I use the latest firmware and I see the messages below at Uart:
    0_1543066245269_upload-e33153dc-5e57-4c57-b4c5-23534b86ffd2
    when I send any command (which trig the uart interrupt) hard fault occurred. I don't know why till now.



  • @msadeghz I mention that when I disable uart interrupt in the code hard fault is not occurred.



  • @msadeghz I have not occured this problem,but we have update the open source version to 2.x.3.2.this firmware fixed some bugs.You could reload the open source latest and refer to the test.https://github.com/RAKWireless/RAK811_LoRaNode



  • hi! i have problem with us915 configuration; ussing at command: "at+band=US915" i have this response from stm32 mcu (with previous configuration of #define LORA_HF_BOARD).

    0_1543858327643_upload-1f1d779b-b05f-4885-b958-f998ff789f67



  • @carlos.soria Maybe the valid scope of the macro definition is not correct,you'd better define it with Global macro as following:
    0_1543981297537_QQ图片20181205114101.png image url)



  • @leopold thank you,
    7 days ago, the source code is updated as:

    update RAK811_LoRaNode firmware version to 2.x.3.2
    1.Fix a debug about "The Hard Fault exception occurs,Reset!".
    2.The end number in version indicate the version with DEBUG or RELEASE :odd:DEBUG ,even:RELEASE.

    I have encountered the first bug. when I connect the module to the supply, I receive continuously the above message. when I disable Uart rx interrupt, I don't receive it.
    0_1545121665061_upload-306b125f-7250-4b11-abfa-15d03dd61af5


    ********** I mention that I use IAR workbench and ST-LINK v2. **********




  • @msadeghz Hi,On IAR workbench,you try increasing the stack space to 0x800. Operational approach on IAR IDE:
    Project->Options->Linker->config->Edit->Static/Heap Sizes->ListData stack(CSTACK):0x800.



  • @leopold thank you Leopold, the issue is solved. I add the startup code from "iar" folder in "cmsis" folder and the problem is solved.
    thank you for reply.



Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.