RAK831 and SX1278



  • Hi. I have a problem with interaction RAK831(433MHz)+converter board+Raspberry 3 and RA01( SX1278 based )device. I have two RA01 and one RAK831. Can you plese confirm what RAK831 compatible with any SX1278 based device or only with RAK (811 for example)? Two Ra01 works fine in PtP mode.
    Problem is what I see many CRC errors (else if I use 831 as RX or TX side no matter). Thank you.



  • Hi,
    RAK831 has been tested with some LoRa nodes in Alibaba IoT Certificate Testing Lab, and it has passed Alibaba IoT Certificate Testing. These LoRa nodes come from different companies and some of them are based on SX1278. You can find these LoRa node in the following Link.
    https://certification.aliyun.com/open/#/certificationlist

    About the CRC errors, you can check whether the frequency of RA01 is correct (compatible with LoRa gateway?).



  • Yes. Frequency is correct, I see it with SDRSharp and RTL2832 dongle. I have compared both FFT graphs, SX1278 and RAK831 have same working range, but SX1278(Tx)+SX1278(Rx) work fine and RAK831(Tx)+SX1278(Rx) not work as need. Also I have made test with different frequences with step 10KHz in range 433,8-434,2 MHz 434MHZ is target.



  • RAK831 434MHz SF8
    0_1539695607281_2018-10-16_15-32-01.png



  • RA01 434MHz SF12

    0_1539695649901_2018-10-16_16-10-17.png



  • Here you see different spreading factor but with equal SF will same BW.



  • I've ever met the CRC errors, and it is because i use a 868MHz Gateway hardware as a 470MHz gateway. So, i think your problem may be same with mine.

    OK, firstly, let's confirm that is your RAK831 hardware a 433MHz gateway?
    Can you give me your email? I'll contact you soon.



  • I have opened radio cover shield and both IC is SX1255.
    My email vekli@mail.ru



  • At this moment compatibility RA-01(02) based on SX1278 and RAK 831 is not confirmed any tests. Support can't help with it.



  • As you know, we've tested it with RAK811 node successfully, and we have no RA-01(02) device to test.



  • The problem was fixed. If you use not LoraWan packets need set "lorawan_public": false, in global_conf.json and keep in mind about Lora header type in your own applications.



  • That's great!


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.