Conflicting docs for 831 with WisAp board

  • Hi, for what it's worth .. I used the instructions here and mostly have a working system. It seems to be very temperamental when starting /usr/bin/packet_forwarder/lora_pkt_fwd though. I have not yet pinned it down, but I am pretty sure it's an RAK831 reset issue.

    There is a script called start which talks about pin11 .. but I am actually totally confused about the various pinout and wiring to be honest. I must have it roughly right though. I used the diagram from here !!

  • Hi
    Did you do the SPI patch as suggested in the document I linked to?
    I agree that starting the packet forwarder seems to a bit of a hit or miss afair. There is no reason given why it wont start. It would have been better if an error message was given.
    I still need to figure out how one can make it an auto start because ther is no simple way for a script to figure out if it started or not.
    It seems like this Rak831 WisAp combination is poorly supported with little documentation. It seems much easier to do this with a Raspberry PI instead :(

    The Openwrt build is also mising the IP package so it does not give a unique EUI in the json file because the script fails.
    I had to do mine manually

  • @patmolloy said in Conflicting docs for 831 with WisAp board:

    h. I have not yet pinned it down, but I am pretty sure it's an RAK831 reset issue.

    Hello patmolloy

    It is not the reset issue. as it is built on sx1301 V1.0 which is not FPGA requires a reset before starting the concentrator.
    In RAk831 the pin19 which is the reset pin for sx1301 when you connect to any GPIO pin, you have to pass that pin number you are using, into that script. so that script can reset the concentrator.

  • It even happens after multiple resets. It seems to just start working after a random number of reset/start attempts
    The GPIO number is also not correct. The GPIO pin that is used is GPIO11 but for some reason it is marked as GPO0 on the PCB

  • @Shantanu Hi, Pin 19 on the RAK831 (RST) is connected to Pin 8 on the WisAP (GPIO0).

    The default value the script uses 11 for GPIO.

    I have tried running start 0 .. is that the correct command?

    Thank you.


  • @patmolloy Well, this does not work reliably either. A random number of attempts at executing lora_pkt_fwd will result eventually in it starting. Most attempts fail with "failed to start the concentrator".

    What else can make this process reliable? I want the concentrator to start reliably on a boot.

  • Just use the default value of 11 - I tested it with a meter and it works.
    I wrote a script in the end to start it. Rak really need to get there act together and give propper support for their products.
    The script will allow you to start it and also allow you to log out without killing the script.
    I am a novice at script writing so this might not be the best way to do it. If you use Windows you can load the script with Winscp. You need to change the permissions to make it executable. Winscp can do this if you right click on it and go to properties.
    Put the script in the packet_forwarder directory and run it from there.

    pidof lora_pkt_fwd > /dev/null
    if [ $? != 0 ]
    echo "resetting"
    ./ start
    echo "attempting to start"
    (./lora_pkt_fwd > /dev/null)&
    sleep 1
    pidof lora_pkt_fwd > /dev/null
    while [ $? != 0 ]; do
    (./lora_pkt_fwd > /dev/null)&
    sleep 1
    pidof lora_pkt_fwd > /dev/null
    echo "Started :) $!"
    echo "already started"

    Create a second script to stop it...
    pid=$(pidof lora_pkt_fwd)
    kill $pid

  • Hi,

    WisLora is a whole product which has already been connected and can not be set up by yourself. You can refer to this document to use it.

    When you have a RAK831 module and a MT76xx board, you can refer to this document to set up hardware by yourself.
    7、 Hardware set up
    Connect the corresponding pin with RAK831 and wisap, reset the pin, wisap can choose the pin your own.

  • @LoraX5 Hi, Thanks. I put your script into /etc/rc.local and lo, the forwarder starts on reboot :)

    A bit brute force, but effective!

    Would like Rak to get to the bottom of the problem though. And I am still confused about GPIO0 vs GPIO11 !!



  • I had some other problems with mine. Kept dropping out of RX mode. I found that the power supply that came with it was a bit suspect regarding supplying 2A. I have added a capacitor across the 12v input and another one across the 5V going to the gateway pcb. This seems to have fixed it.

  • This post is deleted!

  • I see that Rak has released a new version of software that includes a script similar to the one that I posted above, so that the gateways automatically starts. So this is no longer a user requirement

Log in to reply

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.