WisLTE_Arduino setup



  • Hi all,

    @xc.c mentioned the release of new code for WisLTE on https://github.com/RAKWireless/WisLTE_Arduino

    Previously I was running this code on an Arduino UNO connected to the WisLTE:

    void setup() {
    Serial.begin(115200);
    while (!Serial){ ; // wait for serial port to connect. Needed for native USB port only
    }
    Serial.write("ATE0\r\n"); // Turn off the BG96 echo function
    delay(100);
    Serial.write("ATI\r\n"); // Check the basic information of BG96.
    }
    }
    void loop() {
    if (Serial.available()) { Serial.write(Serial.read()); } }

    This was working kind of ok (sometimes it would repeat AT infinetely)

    Now I tried to put this sketch on the UNO:

    #include "WisLTEBG96Serial.h"
    #include "SoftwareSerial.h"

    #define DSerial Serial1
    #define ATSerial Serial
    //#define AT_TX_PIN 11
    //#define AT_RX_PIN 10
    //SoftwareSerial DSerial(AT_RX_PIN, AT_TX_PIN);

    WisLTEBG96Serial WisLTE(ATSerial, DSerial);

    void setup(){
    DSerial.begin(115200);
    while(DSerial.read() >= 0);
    DSerial.println("This is the WisLTE Debug Serial!");
    delay(1000);

    ATSerial.begin(115200);
    }

    void loop(){
    WisLTE.AT_bypass();
    }

    When uploading the sketch to the UNO, I got :
    exit status 1
    'Serial1' was not declared in this scope

    So I uncommented the 3 commented lines and tried to upload again.

    #define DSerial Serial1
    #define ATSerial Serial
    #define AT_TX_PIN 11
    #define AT_RX_PIN 10
    SoftwareSerial DSerial(AT_RX_PIN, AT_TX_PIN);

    This time it compiled, but there is nothing on the serial.

    Do you know what I am doing wrong?
    Thanks!

    PS here are my jumper settings:

    P1 1 connected to 3
    P1 2 connected to 4
    J1 not connected
    J2 connected
    J3 not connected
    J5 not connected
    P2 3 connected to 4


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.