RAK812/Node UART-Setting AT-Command confusion



  • Hello,

    I tried to change the UART-Setting of a RAK812 with weird results.

    1. AT-Command Datasheet reflects not basic setting of module / Datasheet wrong

    -> Datasheet:
    <stop_bits>=<1/2> --------- 0=Stop bit length is 1 bit
    1=Stop bit length is 2 bit
    (where is the 2? I see 0 and 1)

    -> Result of module after at+uart:
    OK115200,8,1,3,0<\r><\n>
    (what does the 3 mean? Stop bit 1+2?)

    1. Tried to set a different speed (38400bps). This is nearly impossible. The module answers sometimes with ERROR -1, or (much more interesting) with OK and does not change anything. Example -> Issued command at+uart=38400,8,1,1,0 -> Answer module is OK -> Reset -> Module still at 115200,8,1,3,0.

    2. The basic and common sense setting 8N1 is not possible to send to the module. But obviously the module is communicating with that setting (according to my terminal software).

    Would be nice to get some assistance on this point. Thanks!


  • administrators

    Thank you very much for your question, this is indeed a problem with our documentation and firmware, we will improve this later.



  • Thank you!

    Please don't hesitate to long, as I plan to introduce our prototype at a conference early October.

    Reference -> Communication with CalibreRF regarding offer and dimensions breakout board (where we have no answer until now).

    Regards


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.