RAK831 Pilot Gateway failed to start the concentrator



  • Dear RAK team, thank you for the fast delivery of the RAK831 868MHZ Pilot Gateway SX1301+Raspberry Pi3+GPS MHz.
    I followed the RAK831 Pilot Gateway User Manual V1.0.pdf and was able to do all steps, but have a problem with the connection to the things network.

    ERROR in dashboard.resin.io

    23.07.18 17:30:54 (+0200) main 15:30:54 INFO: [Transports] Initializing protocol for 1 servers
    23.07.18 17:30:54 (+0200) main 15:30:54 INFO: [TTN] server "bridge.eu.thethings.network" connected
    23.07.18 17:30:54 (+0200) main 15:30:54 INFO: [main] Starting the concentrator
    23.07.18 17:30:54 (+0200) main 15:30:54 ERROR: [main] failed to start the concentrator

    do you have a suggestion?



  • Confirmed, I'm seeing this too after following the instructions in the User Manual.



  • I tested the RAK831 hardware today with Raspbian and "https://github.com/ttn-zh/ic880a-gateway.git ~/ic880a-gateway" and was able to connect to the server "router.eu.thethings.network" after reset the concentrator with:
    #---------------------------------------#
    #!/bin/bash
    echo "17" > /sys/class/gpio/export
    echo "out" > /sys/class/gpio/gpio17/direction
    echo "1" > /sys/class/gpio/gpio17/value
    sleep 5
    echo "0" > /sys/class/gpio/gpio17/value
    sleep 1
    echo "0" > /sys/class/gpio/gpio17/value
    #--------------------------------------#

    So it doesn't seem a hardware or connection problem, and it would be nice if you could correct the "RAK831 Pilot Gateway User Manual V1.0.pdf" manual.
    Because the resin.io way like described in the manual is a clever solution if one have a fleet of RAK831 Gateways.
    If you have questions or need logfiles, just let me know.
    thanks.



  • @osch Thank you for your attempt, we will correct the documentation.


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.