RAK811 as Arduino Uno Shield



  • Hi!

    I've problem with communication while using RAK811 board as a Arduino shield (jumper caps 5_3R <-> TXD and 5_3T <-> RXD). In serial port monitor I see only comands, which Arduino sends to the shield. Later I tried other pin configuration (added CRX <-> TXD and (CTX <-> RXD) and then in response (Tx led on LoRa board blinks) I get some weird letters.

    I'm using example code JoinNetworkOTAA from RAK811 library with updated keys to connect my TTN app using OTAA.

    Thank you in advance for your involvement :)

    Igor



  • 1st attemption
    alt text
    alt text

    2nd attemption
    alt text
    alt text



  • Please set the baud rate of the module to 9600 and try again.



  • I have the same problem. It's not the baud rate.
    When I use the board standalone with a usb directly connected it works with AT commands (on com 7).
    Arduino gives me com 8 where the uploads works.
    Looks like the program stays on com 8 but doesn't connect/talks to the lora board.
    This virtual serial port option (/ATSerial) doesn't look to be working as expected.
    Harald



  • @xc.c I tried almost every baud rate :)

    But could you tell me which jumper caps configuration is properly?

    Changed baud rate to 9600 using at+uart=9600,8,0,0,0 and then in example code from RAK811 library.

    Effects are the same like earlier.

    This is response on at+version command after change baud rate to 9600 :)

    alt text



  • @etihad
    maybe try a different terminal program to check if the settings are not messed up. I tried at 9600 and it worked using Termite. (https://www.compuphase.com/software_termite.htm).

    When I connected the USB ports of both boards I could watch both com ports at 9600. (I used your jumper settings of the last picture.) That worked only the communication between the boards is giving problems, looks like the results are not coming back. I had to strip the checks of the return values (strip if statements) to get it sending data.
    Harald



  • if you want to use WisNode-LoRa to connect Arduino UNO, you need to wire this way:
    0_1529921806256_Screen Shot 2018-06-25 at 6.15.15 PM.png

    If you use our Arduino reference example, you need to use two serial pins, one as a serial port for sending AT commands and one as a debug output port.
    https://github.com/RAKWireless/RAK811/tree/master/Arduino Library

    At this point you need to wire this way:
    0_1529921997882_Screen Shot 2018-06-25 at 6.19.36 PM.png

    After the program download finishes running, you should see this message on the debug serial port:
    0_1529922251975_Screen Shot 2018-06-25 at 6.22.27 PM.png

    The Arduino sample program is just for reference. It implements OTAA network access or ABP network access and wants the gateway to send a packet of data. If you need to implement other functions, you need to develop it yourself.



  • I changed the jumpers and stacked the 2 boards.
    com7 of the Wisnode gives no output, the Uno on com8 gives a loop without sending.

    0_1529937217900_IMG_20180625_155744.jpg

    0_1529937228494_IMG_20180625_155718.jpg



  • @xc.c

    Now I've got half-success. :)

    I established connection to TTN, but still can't see return messages from LoRa board. Is it possible using only Arduino?

    And extra question out of topic - which pin should I bend to upload Arduino sketches without disassembling LoRa board?

    EDIT:
    I forgot to mention, I changed SoftwareSerial pins to 1 - Tx, 0 - Rx. After this change I connected to TTN, but in my opinion it is not properly configuration.

    EDIT2:
    I bent pin corresponding to RESET on Uno board and still have :
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00



  • @etihad said in RAK811 as Arduino Uno Shield:

    but still can't see return messages from LoRa board.

    What kind of return messages do you need?



  • @Harald said in RAK811 as Arduino Uno Shield:

    com7 of the Wisnode gives no output,

    Are you the first time to contact Arduino? You do not need to connect the CON1 of the WisNode board. You need to connect the Arduino D10 and D11 pins to view the debug information.



  • @xc.c

    New to RAK boards.
    I expect when I buy a board that the documentation will give you full info how to use it and have examples that work so you have a good base to work from.
    I didn't expect to run to so many unknowns to get the most basic things like an example from the manufacturer to run. Of cause I have to bring in my personal parameters but to struggle with topics like how to jumper and wire the board with the examples I should get that from the documentation and not a support forum. I lose a lot of time figuring things out that should have been obvious. Looking arround I'm not the only one.
    You have been great in providing a lot of deep technical info and documentation I'm just missing some parts to get up and running smoothly.
    Using for example an Arduino board it would be handy to see in the documentation with the examples how to:

    1. jumper the board.
    2. how to wire/stack it (so people don't have to experiment with bending reset pins) on both sides named per pin from-to.
    3. environment; software with links where to download and settings like baudrate.

    At the end things will run but it takes a lot of unnecessary hurdles to get there, time I would like to spent on creating things not troubleshooting out of the box.

    Harald



  • @xc.c

    @xc.c

    what I expect as returns?
    I'ts more what you expect as a return in the code to proceed like:
    " if(RAKLoRa.rk_setWorkingMode(WORK_MODE))" , I never get in that loop because the return criteria of the function are never met .
    Probably wrong settings/wiring/connections and who knows what else.

    Harald



  • Maybe our engineers brought in their own personal usage habits when writing documents, which led to not writing in great detail. Your advice is very well. We will modify the document later.



  • @xc.c
    Thanks,
    You got my message and I'm glad to see RAK whant's to improve things for users.

    Harald



  • @xc.c

    Could you help me with a clear understanding how to wire the original Uno to the Wisnode and verify the jumper settings when using the OTAA example?

    0_1530003328800_IMG_20180626_104838.jpg

    regards,
    Harald



  • @Harald
    I have already answered how to connect and give a picture.If you don't have a USB-to-serial accessory, you can connect it like this.
    0_1530022774315_upload-4958d492-698d-4a64-a07c-56ea5b250388



  • @xc.c

    That helped.

    Stacking and connecting those 2 worked.
    I can see the result on both com ports.

    thx,

    Harald



  • I can only agree with Harald when he talks about the documentation!
    I stacked the WisNode onto an Arduino Uno trying to communicate with the WisNode via SoftwareSerial, TX on pin 10 and Rx on pin 11. I set up the jumpers as you showed and connected to pin 10 and 11 as drawn on the photo. However, I don't get the answer "ok" from the WsiNode when sending at commands. When connecting a USB to serial interface to pins 10 and 11 I see that the at command is sent on those pins.
    Uli



  • In fact I saw that the boot jumper was in the wrong position. Yesterday I made a backup copy of the flash. When putting it right, I cannot flash the Arduino any more. Seems that Serial0 is still connected to the WisMode who answers when flashing occurs.


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.