Failed to start the concentrator on RAK 831 + FT2232H + TTN iC880a-based gateway



  • Hello,
    I followed the instructions to set up a gateway using FTDI.
    Make connections according to "RAK831+FT2232HL Quick Start
    Guide V1.2".

    Register the gateway at TTN and configure global_conf.json according to https://github.com/TheThingsNetwork/gateway-conf/blob/master/US-global_conf.json.

    I made the change at local_conf.json, it looks like this:

    {
    "gateway_conf": {
    "gateway_ID": "1001100110011001",
    "servers": [ { "server_address": "router.us.thethings.network", "serv_port_up": 1700, "serv_port_down": 1700, "serv_enabled": true } ],
    "ref_latitude": 0,
    "ref_longitude": 0,
    "ref_altitude": 0,
    "contact_email": "irvinvp@gmail.com",
    "description": "ttn-ic880a"
    }
    }

    But the log always shows:

    INFO: gateway MAC address is configured to 1001100110011001
    INFO: Found 1 servers in array.
    INFO: Server 0 configured to "router.us.thethings.network", with port up "1700" and port down "1700"
    INFO: packets received with a valid CRC will be forwarded
    INFO: packets received with a CRC error will NOT be forwarded
    INFO: packets received with no CRC will NOT be forwarded
    INFO: Reference latitude is configured to 0.000000 deg
    INFO: Reference longitude is configured to 0.000000 deg
    INFO: Reference altitude is configured to 0 meters
    INFO: GPS is disabled
    INFO: antenna_gain 0 dBi
    INFO: Upstream data is enabled
    INFO: Downstream data is enabled
    INFO: Ghoststream data is disabled
    INFO: Radiostream data is enabled
    INFO: Statusstream data is enabled
    INFO: Beacon is disabled
    INFO: Monitor is disabled
    INFO: Contact email configured to "irvinvp@gmail.com"
    INFO: Description configured to "ttn-ic880a"
    INFO: Successfully contacted server router.us.thethings.network
    INFO: [main] Starting the concentrator
    ttn-gateway ttn-gateway[2083]: ERROR: [main] failed to start the concentrator
    ttn-gateway systemd[1]: ttn-gateway.service: Main process exited, code=exited, status=1/FAILURE
    ttn-gateway systemd[1]: ttn-gateway.service: Unit entered failed state.
    ttn-gateway systemd[1]: ttn-gateway.service: Failed with result 'exit-code'.

    What can I do?. There is some RAK manual for mounting a LORAWAN TTN server but using FTDI.

    Thank you



  • Solved.

    Connect GPIO17 (Pin 11 from Raspberry) to RST (Pin 19 RAK 831)
    Conect GPIO25 (Pin 22 from Raspberry) to RADIO_RST(pin 13 RAK831)

    And add this code at begin of start.sh

    Reset iC880a PIN2

    SX1301_RESET_BCM_PIN_2=17
    echo "$SX1301_RESET_BCM_PIN_2" > /sys/class/gpio/export
    echo "out" > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN_2/direction
    echo "0" > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN_2/value
    sleep 0.1
    echo "1" > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN_2/value
    sleep 0.1
    echo "0" > /sys/class/gpio/gpio$SX1301_RESET_BCM_PIN_2/value
    sleep 0.1
    echo "$SX1301_RESET_BCM_PIN_2" > /sys/class/gpio/unexport


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.