RAK 833



  • Hello,
    I have received my rak833 devkit, and I am not able to start the modem. Packet forwarder display this message :
    NFO: downstream port is configured to "1700"
    INFO: downstream keep-alive interval is configured to 10 seconds
    INFO: statistics display interval is configured to 30 seconds
    INFO: upstream PUSH_DATA time-out is configured to 100 ms
    INFO: packets received with a valid CRC will be forwarded
    INFO: packets received with a CRC error will NOT be forwarded
    INFO: packets received with no CRC will NOT be forwarded
    ERROR: [main] failed to start the concentrator
    root@OpenWrt:/usr/bin/packet_forwarder#

    Do you have a solution ?
    thanks



  • My bad ...
    I put a gateway id with uppercase char ... it is necessary to have a gateway id with lowercase


  • administrators

    Hi, tasul
    I'm glad that you use our company's product, according to the information you provide, I think that you want to connect TTN, and configure the gateway configuration errors please follow the steps to configure your gateway of this link link text, if still not successful, please reply and attach detailed information (such as photos)

    regards



  • Hello,
    My issue is related to the rak833 with eval board instead of rak831 with a rpi. I have configure my rak831 early and everything works fine.

    But with the rak 833 eval board I have some problem. When I am starting the packet forwarder by hand it is crash. And After several attempts it will work (see log section). I am not able to have more log from the packet forwarder.

    Could yo u also send me the jumper information of the eval board ?

    Thanks

    log section
    INFO: downstream keep-alive interval is configured to 10 seconds
    INFO: statistics display interval is configured to 30 seconds
    INFO: upstream PUSH_DATA time-out is configured to 100 ms
    INFO: packets received with a valid CRC will be forwarded
    INFO: packets received with a CRC error will NOT be forwarded
    INFO: packets received with no CRC will NOT be forwarded
    ERROR: [main] failed to start the concentrator
    root@OpenWrt:/usr/bin/packet_forwarder# vi global_conf.json
    root@OpenWrt:/usr/bin/packet_forwarder# ./lora_pkt_fwd
    *** Beacon Packet Forwarder for Lora Gateway ***
    Version: 4.0.1
    *** Lora concentrator HAL library version info ***
    Version: 5.0.1;


    INFO: Little endian host
    INFO: found global configuration file global_conf.json, parsing it
    INFO: global_conf.json does contain a JSON object named SX1301_conf, parsing SX1301 parameters
    INFO: lorawan_public 1, clksrc 1
    INFO: LBT is disabled
    INFO: antenna_gain 0 dBi
    INFO: Configuring TX LUT with 16 indexes
    INFO: radio 0 enabled (type SX1257), center frequency 867500000, RSSI offset -166.000000, tx enabled 1, tx_notch_freq 129000
    INFO: radio 1 enabled (type SX1257), center frequency 868500000, RSSI offset -166.000000, tx enabled 0, tx_notch_freq 0


  • administrators

    Hi,

    Your reply has been received, please contact our project (email:Mr. chenfarce.chen@rakwireless.com
    ), please attach details of your question.

    regards



  • Hi tasul
    Can you try to enter the usr/bin/lora, perform the:reset./reset_lgw.sh star.
    0_1526712035619_upload-971782dd-2516-41bd-bc26-70742c1bb7f4
    After performing the reset, test the SPI interface to see if the communication is normal, and execute the SPI communication:. Test.testloragws.The running values need to be consistent, which means that the SPI communication is normal, as shown in the following figure:0_1526712114075_upload-7e889a7c-49e8-404b-b459-e1ae39ac0d6d
    SPI test is normal to enter the radio frequency test:
    TX command set
    ./util_tx_test -r 1257 -f 868.3 -b 125 -s 12 -p 27 -t 111
    Available options:
    -h print this help
    -r <int> radio type (SX1255:1255, SX1257:1257)
    -n <uint> TX notch filter frequency in kHz [126..250]
    -f <float> target frequency in MHz
    -k <uint> concentrator clock source (0:Radio A, 1:Radio B)
    -m <str> modulation type ['LORA', 'FSK']
    -b <uint> LoRa bandwidth in kHz [125, 250, 500]
    -s <uint> LoRa Spreading Factor [7-12]
    -c <uint> LoRa Coding Rate [1-4]
    -d <uint> FSK frequency deviation in kHz [1:250]
    -q <float> FSK bitrate in kbps [0.5:250]
    -p <int> RF power (dBm) [ 0dBm 10dBm 14dBm 20dBm 27dBm ]
    -l <uint> LoRa preamble length (symbols)
    -z <uint> payload size (bytes, <256)
    -i send packet using inverted modulation polarity
    -t <uint> pause between packets (ms)
    -x <int> nb of times the sequence is repeated (-1 loop until stopped)
    --lbt-freq <float> lbt first channel frequency in MHz
    --lbt-nbch <uint> lbt number of channels [1..8]
    --lbt-sctm <uint> lbt scan time in usec to be applied to all channels [128, 5000]
    --lbt-rssi <int> lbt rssi target in dBm [-128..0]
    --lbt-rssi-offset <int> rssi offset in dB to be applied to SX127x RSSI [-128..127]
    RX command set:
    ./test_loragw_hal -a 868.3 -b 867.3 -t 868 -r 1257 -k 1

    ./test_loragw_hal -h
    Library version information: Version: 5.0.1;
    Available options:
    -h print this help
    -a <float> Radio A RX frequency in MHz
    -b <float> Radio B RX frequency in MHz
    -t <float> Radio TX frequency in MHz
    -r <int> Radio type (SX1255:1255, SX1257:1257)
    -k <int> Concentrator clock source (0: radio_A, 1: radio_B(default))



  • Hello,
    I also have the RAK833 with an EVB board. I get
    ERROR: CONCENTRATOR UNCONNECTED on the EVB board when i run any of the test scripts ( ./test_loragw_reg) but I can connect to the concentrator and see packets if connected to a laptop via USB on CON2.

    What are the correct jumper settings?
    What packet forwarder are you using? Can you share a link?



  • @aizukanne You can try to excute the following command: sudo ./test_loragw_reg.


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.