LoraButton Bricked



  • I think I made a mistake, I upgraded my LoraButton with the file bin/u_rak811_lorabutton.bin from official repo
    https://github.com/RAKWireless/RAK811_LoRaButton

    I've done it with RAK LoRaButton Upgrade Tool V1.0 and upgrade went fine but I can't do anything more, seems bricked, nothing on serial and I cant flash it or use it either
    How can I get back to life ? I've got STM32 programmer STLink.

    On my second one I flashed firmware from RAK Wireless support site
    U_RAK811N_LoraButton_V2024_EU868_20180312 and worked fine.

    Thanks for your help



  • Got it, I tried something and it worked
    Removed lipo then plug usb cable while pressing button (looks like number 2) then 3 led are flashing red and one green.
    Looks like button in firmware mode, then tool was able to flash it back.

    Not mentioned anywhere on documentation for firmware updating



  • Hello, the open source project you have seen is for the open source project of RAK_LB801 that we launched later. The difference between the current RAK_LB801N LoRaButton and the current one is shown in the figure below, so do not mix their data.
    0_1523584943680_屏幕快照 2018-04-13 上午10.01.57.png



  • @xc-c
    thanks for this information, may be worth mentioning on OpenSource github repository readme file.


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.