CreatorPro is stucked in bootloader mode



  • Hi! I hope you are very well.
    I received a RAK611 dash button (V12) with RAK473 WIFI module and a Creator Pro board a few weeks ago and I've been having some problems with creator pro. I followed the pdf document about the dash button example that is available on the web site but I am still not able to make it work. I did connect the cables as indicated on the document, and then I tried to upload a simple example to creator pro. At first time the program was uploaded succesfully but it never worked (even using a predefined example). After some more attempts, when I was uploading the program, creator pro started to plug out and in again itself, and on the MBED device appeared a text file called "fail.txt" and it had just one text line that said "SWD Error". I was looking for this error here and in another blogs, and in many of these sites they was saying that it could be a firmware problem, and that the firmware should be updated. So I followed again a document on RAK website about how to update Creator Pro firmware. I followed the document step by step, i did download the new firmware and I changed the old one. The last step say "unplug creator pro and plug in again, and the new firmware should work normally". I did it and from that moment Creator Pro is stucked in bootloader mode, and never returns to work as a mbed device, and PC only recognize it as "CRM DSBLD".

    What can I do to restore Creator Pro? Is there some way to turn it out of the bootloader mode? Any hint about why it never worked normally?

    Thank you so much.

    Mauricio



Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.