RAK811 AT+DR Issue

  • I am using a RAK811 with V2022 AS923 firmware flashed.

    There are two types of packets my device will typically send, with different DR. The most common type of packet is sent with a DR of 3 (SF9BW125 for AS923). Therefore, the default DR of the RAK811 is set with "at+set_config=dr:3".

    When sending the other type of packet, the following commands are sent:
    "at+dr=5" (temporarily set to SF7BW125)

    However, the temporary data rate is not being used consistently, as shown in the gateway log below. Sometimes, the default data rate of SF9BW125 is used instead.

    I have not encountered other issues with the module. Is there anything else to check? Could there be a bug in the module firmware?

    Edit: The RAK811 responds with "OK" to "at+dr=5".

    0_1517198906142_SF issue.png

  • Hello sir

    Have you use the "at+dr=5" for every send before ?
    We will check it soon.


  • Hello sir

    We test seems OK.
    Other question, see from your log, you send data from other channels 922.8 923.0, have you set the channelmask?


  • @junhua
    "at+dr=5" is sent before every "at+send".

    Also, I did not set any channel mask. I presume the channel list is updated when the device joins by OTAA.

    Is there an issue with setting the DR temporarily if other channels are used besides the defaults?

  • @andrewtjs
    From your log, seems can not see the channel list downlink commands from TTN. Here we test channels not be update , can you help confirm the channel list ?

    If set other channels by channelmask , dr also not change.


Log in to reply

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.