Why send AT command device not respones?


  • administrators

    @hanmant What device are you using? How to use it?



  • @rakadmin im using Lora RAK811.i was trying get the device version by AT command


  • administrators

    Please take a photo of your device. Thanks



  • @administrators i have a RAk812 433Mhz operated and i try to connect it to the gateway Rak831 which is already connected to the TTN with 433Mhz config with the local json file
    and when i try to connect my node to gateway or node to TTN it seems my node wont connect here is the response i get when i try to at+join=otaa.
    ![alt text](0_1518527287431_upload-e448687d-6189-4cf3-8e1e-b9a672f37ba6 image url)



  • @clefford218 @administrators I am having the same issue with a 915MHz RAK811 and Rak831 Gateway (connected to TTN). I tried OTAA (returns 6,0,0) and both ABP (no join status returned after "OK") multiple times without success.



  • @tlocke01 i connected my 433Mhz Gateway to a different server and successfully joined my node to the server and i'm trying now to send data and see uplinks and downlinks



  • Can someone share a step by step guide of how to send AT commands to the RAK811 board in Mac? I use screen in terminal and I also tried using a SerialTool app but it seems to me I have only got a 'read only' serial monitor mode, as I cannot 'send' any AT command.



  • @coeus I think your problem is that OS X (as well as virtually any operating system besides DOS and Windows) sends a line feed if you press enter. RAK811 original AT firmware expects DOS style line endings (carriage return, followed by line feed). Screen under OS X sends newline only. You can try CuteCom. I use it under Linux, because you can select the line endings there .



  • Hello, i had the same issue, but i'm in linux. Ubuntu, to be more specific.

    Model: RAK811 1817
    Jumpers: CRX-TXD,CTX-RXD and BOOT-GND

    I tried the following commands and it worked:

    Configure to 8-N-1

    stty -F /dev/ttyUSB0 115200 cs8 -cstopb -parenb -echo

    To see the version:

    echo -e "at+version\r" > /dev/ttyUSB0

    I hope it will help somenone



  • Open two terminal ( run as root )

    in first terminal - ( it is to receive the serial data from device )
    cat /dev/ttyUSB0

    in second terminal-
    echo "at+version" > /dev/ttyUSB0

    You should see the version in the first terminal.

    0_1538668710224_2.png


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.