RAK811 Tracker - HowTo

  • Hi,
    I've got my RAK811 Tracker module some days ago.
    I tried to do all steps like described in RAK811 "TrackerBoard User
    Manual V1.0".
    Some questions (sorry I am beginner):

    1. Do I have to install new firmware like described or is actual firmware on the module?
    2. How to connect J-link to the device's SWD interface? Do I need additional Hardware?

  • administrators

    1. The manual describes three kinds of firmware programming. If you are not familiar ,Can you tell me what is your familiar way?
    2. You must have a j-link device. https://fr.aliexpress.com/store/product/JLINK-V9-Emulator-Kit-Simulator-with-Convert-board-USB-cable-Black-color-debugging-tools-AMR-Emulator/2805180_32828353970.html?spm=a2g0w.12010608.0.0.2f106b33izmAtN

  • I don't have J-link, but tried to connect the module to TTN.
    Managed the settings on TTN, then I headed to set up the module with AT commands as per referenced in the How To Connect LoRa RAK811
    To The Things Network
    manual. Finally the tracker appeared on TTN, but after two successfully sent packets the serial interface reports Tx errors, as follows:

    Tx Err: 1
    [Debug]: tempr: 25
    Tx Err: 1
    [Debug]: tempr: 28
    Tx OK: 02 67 01 18
    [Debug]: tempr: 26
    Tx OK: 02 67 01 04
    [Debug]: tempr: 30
    Tx Err: 1
    [Debug]: latitude: 47.xxx, longitude: 19.xxx , altitudeGps: 176
    Tx Err: 1

    Then after a few unsuccessful attempts it sends two packets again without any problems, then starts reporting TX errors again...

    Is there a way to fix it somehow? Or I must get a JLink?
    thx, r

  • Hi,

    I installed the CooCox CoIDE, downloaded the software from GitHub, set up a new application and device at TTN (TheThingsNetwork) and filled in the required 3 keys in "Comissioning.h"
    I was able to compile a .bin file which I uploaded to the node via "Flash Loader Demonstrator" from ST.
    The node reports Region AS923.

    RAK811 BreakBoard soft version: 1.0.2Selected LoraWAN 1.0.2 Region: AS923

    I am in Europe and ordered the EU version of the node.

    How can I change the node to Region EU868?

  • administrators

    @rdosa You must have a j-link to program the device.

  • administrators

  • Hi,
    now I have a J-Link Interface (Segger) but how to connect to RAK811 Trackerboard?
    Is there a schematic/pin-diagram how to connect?

  • administrators


  • @frml55 you should also check the JLink user guide for the pinouts of your debugger http://www.farnell.com/datasheets/1562851.pdf

  • @rakadmin Does it mean that I must have J-link even to put the Devices EUI, App EUI and App key into the RAK811 Trackerboard?

    I purchased the J-Link through your taobao store but I am not sure if I can use it on my Virtualbox with Windows 7.

    Can I have the environment set up in Ubuntu Linux?

    I just want to setup the Lora Tracker to test in Cayenne MyDevice for now.

  • administrators

    Hello, we currently only provide the Windows environment, if you want to download the program in the Liunx environment, you need to modify the procedures for the gcc compiler environment.

  • @olunia

    Try this, it's work on debian and ubuntu


  • Hi,
    FYI, i just update the Makefile (some settings were "conflicting")...

  • Hi,
    now I have connected the Segger J-Link adapter like this:

    I've installed CoIDE on my Windows10 PC and "GNU Tools ARM Embedded - 6 2017-q2-update"

    When I try to build I get compiled 56 files without a failure, but when start linking
    the following failure appears:

       [cc] Starting link
       [cc] arm-none-eabi-gcc -mcpu=cortex-m3 -mthumb -g2 -nostartfiles -Wl,-Map=RAK811Breakboard_classA.map -Os "-LC:/Eigene Dateien/0_Familienmitglieder/Maze/IOT Allgemein/RAK811 Tracker/coIDE/classA" "-Wl,-TC:/Eigene Dateien/0_Familienmitglieder/Maze/IOT Allgemein/RAK811 Tracker/coIDE/classA/link.ld" -g -o RAK811Breakboard_classA.elf ..\obj\sx1276.o ..\obj\printf.o ..\obj\stm32l1xx_hal_rcc.o ..\obj\stm32l1xx_hal_adc.o ..\obj\lis3dh.o ..\obj\gps-board.o ..\obj\startup_stm32l151xb.o ..\obj\sysIrqHandlers.o ..\obj\gpio-board.o ..\obj\stm32l1xx_hal_uart.o ..\obj\uart-board.o ..\obj\gps.o ..\obj\stm32l1xx_hal_pwr.o ..\obj\Region.o ..\obj\stm32l1xx_hal_spi.o ..\obj\LoRaMac.o ..\obj\fifo.o ..\obj\RegionKR920.o ..\obj\timer.o ..\obj\stm32l1xx_hal_gpio.o ..\obj\uart.o ..\obj\rtc-board.o ..\obj\stm32l1xx_hal_cortex.o ..\obj\utilities.o ..\obj\main.o ..\obj\stm32l1xx_hal_rtc.o ..\obj\cmac.o ..\obj\adc-board.o ..\obj\aes.o ..\obj\system_stm32l1xx.o ..\obj\sx1276-board.o ..\obj\RegionEU868.o ..\obj\RegionUS915-Hybrid.o ..\obj\RegionAS923.o ..\obj\RegionCommon.o ..\obj\LoRaMacCrypto.o ..\obj\stm32l1xx_hal_i2c.o ..\obj\RegionIN865.o ..\obj\stm32l1xx_hal.o ..\obj\delay.o ..\obj\RegionAU915.o ..\obj\spi-board.o ..\obj\stm32l1xx_hal_rcc_ex.o ..\obj\stm32l1xx_hal_adc_ex.o ..\obj\eeprom-board.o ..\obj\stm32l1xx_hal_dma.o ..\obj\board.o ..\obj\i2c-board.o ..\obj\stm32l1xx_hal_spi_ex.o ..\obj\stm32l1xx_hal_pwr_ex.o ..\obj\gpio.o ..\obj\adc.o ..\obj\RegionUS915.o ..\obj\i2c.o ..\obj\stm32l1xx_hal_rtc_ex.o ..\obj\stm32l1xx_hal_usart.o -lm -lgcc -lc -lrdimon
       [cc] ..\obj\startup_stm32l151xb.o:(.isr_vector+0x0): undefined reference to `_estack'
       [cc] c:/program files (x86)/gnu tools arm embedded/6 2017-q2-update/bin/../lib/gcc/arm-none-eabi/6.3.1/../../../../arm-none-eabi/lib/thumb/v7-m\libc.a(lib_a-init.o): In function `__libc_init_array':
       [cc] collect2.exe: error: ld returned 1 exit status
       [cc] init.c:(.text.__libc_init_array+0x20): undefined reference to `_init'

    Can anyone help me to build my .bin file?

  • The problem with failed linking is solved.
    CoIDE's configurtion of link file was wrong.
    After I corrected this I've got my bin file, but ...

    • How to get the code in the RAK811 tracker flash?
    • How to connect to TTN?
    • How to connect to Cayenne to test the tracker?

  • Hi,
    in commissioning.h the EUI Values are in "big endian".
    If I build the project with big endian byte format, it doesent works.
    If I build it in little endian it works but activation in TTN doesn't work?!

    What to do?

    Options for code generation (crossStudio) are:

    • Little little endian code and data.
    • Big big endian code and data.
    • BE-8 little endian code and big endian data.

  • It's Chinese New Year so we may have to wait for some answers. I'm facing similar problems.
    When RAK say on there Boxes IoT made easy, what do they mean? it dose not looks that easy to me. Than again I'm not a developer dealing with embedded code. I hoped it would have been a config file you edit and that's it. Can you please continue to share your progress as this would greatly help me and I'm sure many other frustrated owners of the RAK 811 tracker. Thank you

  • administrators

    @frml55 said in RAK811 Tracker - HowTo:

    How to connect to TTN?
    How to connect to Cayenne to test the tracker?

    About this problem ,please see the document:http://docs.rakwireless.com/en/RAK811 TrackerBoard/Software Development/Node Location Solution Kit With TTN V1.0.pdf

  • Can replace RAK811 by RN2903 of (microchip) ????????

  • May be can not, we do not know much about RN2903.

Log in to reply

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.