RAK811 Tracker - HowTo



  • @barillaro

    1. If you need to flash your .bin file then the jumper should be in this mode0_1524140655430_photo_2018-04-19_17-53-58.jpg

    2. If you need to communicate/at commands with the device you should change the jumper to this position0_1524140706814_photo_2018-04-19_17-53-52.jpg

    Correct me if I'm wrong



  • @maheshblazer1
    You need to modify it in open source projects.
    First find an unused ADC pin, then initialize it to ADC, then read the voltage value of this pin.



  • @xc.c
    how many ADC pins are there in RAK811 sensor node!(i haven't used any pins)
    (As I read from schema PB12, PB14, PB15, PA1 are ADC pins right, correct me if I'm wrong)
    How to initialize them?
    What is the syntax for analog read?

    int sensorValue = analogRead(A0);

    could you write an example code for above line?



  • @maheshblazer1

    Thank you for yours picture! I will try soon and let you know!



  • @maheshblazer1 The pictures helped, thank you. I was able to upload the .bin file and get the proper output on the terminal.

    Another question:
    I did this -->"You should all be done. Unplug, change the jumper back to original position. Power up the board and it should connect to the AP."
    I unplugged, changed the jumper to your picture 2, and plugged it back in.

    I tried this several times. I even took it outside for 5 min. The rak811 never connects to ttn. I have a gateway setup and connected.
    The device and application EUIs and app key have all been changed.

    I am also monitoring using Uart Terminal. The following is what I get:
    Dev_EUI: XXXX...
    AppEui: XXXX...
    AppKey: XXXX....
    OTAA Join Start...

    This is what I see on the ttn:
    0_1524538040708_ttn.PNG

    0_1524543135894_ttn2.PNG

    What am I missing? How do I get my device to connect and map?



  • @Blue_Spring we frequency are you using for your gateway and RAK811?



  • @coeus I am using 915MHz for the gateway.
    For the device, the ttn network shows it connected to "ttn-handler-us-west (current handler)". But the UART terminal states:
    RAK811 BreakBoard soft version: 1.0.2
    Selected LoraWAN 1.0.2 Region: EU868
    OTAA:
    Dev_EUI: XXX..
    AppEui: XXX..
    AppKey: XXX..
    OTAA Join Start...

    I am guessing this is where the problem is. It should be US915 for both instead of EU868 for the device.
    How can I change it? - Thank you

    Edit:
    I changed the frequency of RAK811 to US915 by going to platformio.ini in atom but the problem still persists. I still get:
    OTAA:
    Dev_EUI: xxx...
    AppEui: xxx..
    AppKey: xxx...
    OTAA Join Start...

    What am I missing? - Thanks



  • IM having the same problem, stuck on "OTAA Join Start...."

    Gateway and node had the same region, i checked on the gateway and see a rx and then a tx in the same channel (the specs says tx ch = rx ch modulo 8) so it has sense that almost always the gateway respond to the same channel, but the node can catch the response....

    anybody had this working? can you share node code AND global_conf.json from the gateway please? for US915 or AU915



  • @Blue_Spring

    Hi

    in main.c change the following.

    #if defined( REGION_EU868 )
    to
    #if defined( REGION_US915)

    Should be line 54..



  • @Kevlar042 Do you still have trouble with the EEPROM?



  • hi everybody!
    Is available anyone uart port on rak811 tracker?



  • @carlos.soria The current hardware is not supported, so we have summarized some of the user's opinions and found out where these need to be modified. Do you have anything else to add?

    1. The R1/C1 pin of GPS power switch chip U5 needs to be connected to a pull-up circuit。
    2. Power indicator LED1 light removed. Reserve charge indicator, and two GPIO control status indicators.
    3. The EXTINT0 and ANTON pin of the GPS module needs to be connected to GPIO to facilitate wake-up in low power mode.
    4. CP2102 chip removed, add a serial adapter board accessories。
    5. Add GPIO to detect the power supply type of the device, battery-powered or USB-powered. It can be detected using the power chip PG pin and CHG pin.
    6. Directs one UART interface for users to expand to other devices


  • @qlion

    Great Great Great explanation.
    This is what I was missing in the RAK documentation.
    This way I got it up and running in 1 hour from scratch.

    Many many thx.

    Harald



  • @xc.c HI! I am really new on the stm32 enviroment, but i know on the arduino ide you can use some digital pins for create a virtual serial interface (and you can use ftdi for comunicate with PC). I can do this with stm32 (keil uvision) enviroment?
    For your suggestions can i write:
    1-The recomended desing fot texas for the switch is; correct for your apreciation: R1/C1 connecte to Vin.
    2- for the Power indicator LED1 light you can maybe put a jumper for desingn uses and we can remove the jumper on production enviroment. The reverse charge indicator and two gpio control status are very ussefull.
    3-The ublox gps drink to much current, if you indication is possible; we are thinking on buy alot of rak modules.
    4-For productions cases we dont use the usb module, only use for charging propose with a solar charger.
    5-I don't any example of this use, maybe it be very ussefull. I m only use the voltaje level of battery.
    6-A better antenna for us915 mhz.0_1530192109441_IMG_20180622_111405_1.jpg



  • @carlos.soria

    lol your 915 antenna is more 868 then my 868.
    I could even tune it by shorten the wire and have it maxed on 868.
    Maybe I should ask RAK to swap my 868 for a 915.

    Harald


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.