CREATOR does not upload firmware to dash button

  • I use Arduino IDE with Ubuntu 16.04.

    Everything used to work. I uploaded a firmware a few times. But once it just started returning:

       Build options changed, rebuilding all
    Sketch uses 301454 bytes (14%) of program storage space. Maximum is 2097152 bytes.
    /home/alexeyisme/.arduino15/packages/RAK/tools/ameba_tools/1.0.9/upload_dap_linux /home/alexeyisme/.arduino15/packages/RAK/tools/ameba_tools/1.0.9/ram_all.bin 
    cp "/home/alexeyisme/.arduino15/packages/RAK/tools/ameba_tools/1.0.9/ram_all.bin" /media/alexeyisme/MBED/;sync
    upload finish

    It says upload finish, but dash button firmware is not updated. I think I just don't see what I do wrong.
    Please, help.

  • administrators

    Hi, can you use the windows 7 system to try it?

  • interesting, I have the same problem. I'm on macOS, don't have any windows pc :(

    At the beginning, the upload took a while and I could the LED flashing quick on the Dash (RAK611) while uploading. Now, nothing happens anymore.

    Maybe I stwitched from JTAG to DAP mode? How can I switch back?

  • just found this output in console:

    Start RESET program
    target_set_state : RESET Program failed
    jtag_init() failed
    main : usb disconnected

    That's the problem. but how do I fix the reset program?

  • solved it! I had the OTA example on the dash which apparently called sys_jtag_off(). To fix it, I uploaded a new image via OTA, not using pinMode. Once this was flashed I could upload another image directly over Creator PRO again.

  • Sorry another update: no, NOT solved :( Problem is back again: this time
    I don't have any OTA connected, so no chance to avoid sys_jtag_off() to be called. what to do? which pin is A2 and checks the Battery status? from reading code, this one has to be > 800. Help!

  • if the A2 pin is dangling(without plug battery), the voltage level will be less than 800mv, so the sys_jtag_off() will not be called, and the download process will be normal.


    if not plug battery and still download fail, try click below key to see...

  • hey harry

    thanks for your quick reply. I tried this, but is doesn't help. I'm now trying just to connect the Creator Pro Board to my mac, and even this is not (always) working. I assume the board is broken. the reset DAP chip button works only if I press the button very very hard a couple of time - then the board resets/reboots. Will talk to @rakwireless for advice... :(

  • Can you take a photo about your wire connections?

  • Sure (see below) - I double checked it, it's exactly as displayed on your picture.

    Meanwhile I added an Arduino for the serial communication & reset connection - now the flashing works again in ~80% of the cases. I still assume the Creator PRO Board has something broken... :( Anyway, I can say the flashing problem is SOLVED (for now).

    0_1514378425878_Screen Shot 2017-12-27 at 13.39.59.png

Log in to reply

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.