Issues with the "RAK831" for the testing



  • For the RAK831, I followed the "RAK831 Quick Start Guide V1.0" step by step, at the testing stage I did two tests:
    1-test_loragw_reg: I got a positive result as mention on the guideline, and for the
    2-test_loragw_rx 868.1 868.5: it takes too long (around 30-50 sec) and it show me this error after while "CRC error. damaged packet".
    Here are some notes about my environment:
    1-I'm using "Raspberry Pi 3 model B as host".
    2-I tried the both ways, direct connection with host and using the F2232H board.
    3-I didn't use the remote configuration (didn't create a .JSON file and upload it).
    4-when I tried to reset the rak board, nothing happen to the board and even when I run the test code (is there something supposed to happen? like the power led start to blinking!!, also for the rx led, no response).

    I hope it's clear for everyone and I hope we can resolve this problem soon enough.


  • administrators

    hi,thanks for you questions. My reply is as follows:

    1. you use the RAK831+F2232H board,and do the two tests. It seems to success,and the end "CRC error. damaged packet". I think you lack a LoRa Node to sending data.
    2. you use the RAK831+Raspberry Pi 3 model B. place don't use the Raspberry pie converter board. We found that our converter board was designed with problems.Can you wire yourself?


  • @rakadmin hi, thanks for the quick response, for the:
    point#1: yeah I figure out that I need the node to receive packet that's why I receive this error.
    and for point#2: which converter board do you mean? the F2232H board?
    In my connection now I'm using the F2232H board and when I tried to run the reset script from the "hackster.io" to reset the board nothing happen!! (is there something supposed to happen?? blinking or some else) and when I tried to re-run it again it keep show me this error "rak831_reset.sh: line 2: echo: write error: Device or resource busy" , again I'm using the F2232H board.


  • administrators

    hi,the rak831_reset.sh is base on Raspberry Pi 3, place use Raspberry Pi 3+RAK831



  • @rakadmin

    Hello,

    I am about to purchase one RAK 831 kit with Raspberry Pi 3 and an interface board from AliExpress. Could you please provide me with an information regarding the error on the board. I hope to fix it myself as I really do not like wires around.
    I will be waiting for your reply.
    Thanks a lot in advance.



  • I am also curious about the fault on the converter-board. I received it yesterday, integrated it into my working setup and noticed the software-reset was not working anymore, i had to reset by hand on the board to get it to work.
    Also something got hot so i already stopped using it.
    I am interested to know what has to be changed to make it work..


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.