lsusb bug with rc342 wiscore firmware (lsusb Bug Report )

  • 0_1502467799509_bug lsusb error 99.jpg
    bug report lsusb not working..usb basic support is all installed with this list
    kmod-usb-core kmod-usb-ohci kmod-usb-uhci kmod-usb2 kmod-ledtrig-usbdev usbutils kmod-leds-wndr3700-usb --force-depends .
    package show on luci-system-sofware. and this is dmesg from wiscore fw rc342

    custom firmware from sdk also some problem and this is dmesg log
    and other bug is sdcard slot cannot detect with blkid and block info from my sdcard with ntfs and ext4 partition..please so for some update for lsusb working fine..
    this is custom firmware build by me and my friend link
    include all usb package driver, openvpn , samba share , alexa..this firmware build from wiscore sdk..
    not woking lsusb
    not working mmc support

  • hi erickfloors:
    Now in our wiskcore firmware rc342, it's not install usb-components, so you can't install it through opkg,
    if you want to use usb, you need compile wiscore by yourself:

    1. download wiscore sdk:
    2. compile wiscore as github introduction
    3. add usb-components:
       cd WisCore-SDK/wiswrt/15.05-rak-rc2
    make menuconfig
    Kernel modules —> USB Support —>
    	<*> kmod-usb-core.
    	<*> kmod-usb-ohci.
    	<*> kmod-usb-uhci.
    	<*> kmod-usb-storage.
    	<*> kmod-usb-storage-extras.
    	<*> kmod-usb2.
    Kernel modules —> Block Devices —>
    Base system —>
    Kernel modules —> Filesystems —>
    	<*> kmod-fs-ext4
    	<*> kmod-fs-vfat
    	<*> kmod-fs-ntfs
    if you want to use usb tools please choose:
     Utilities  --->
    	<*> usbutils
     Base system  --->
    	<*> busybox--->
    	Linux System Utilities  --->
    		[*] lsusb
    about sdcard, there are a bug, it don't support hotplug, you need plugin sdcard before power on, and we'll solve the problem later
    Enable sdcard:
    cd WisCore-SDK/wiswrt/15.05-rak-rc2
    vi target/linux/ramips/dts/MT7628.dts
    add dts just like uart1:
    	sdhci@10130000 {
                           status = "okay";
    make menuconfig
    Kernel modules —> Other modules —>
    	-*- kmod-sdhci
    	<*> kmod-sdhci-mt7620
    	-*- kmod-mmc
    Kernel modules —> Native Language Support —>
    	< *> kmod-nls-cp437
    	< *> kmod-nls-iso8859-1
    	<*> kmod-nls-utf8
    4. compile
    5. burn firmware
    refer  to:
    6. after the system start when plugin usb you can see, /dev/sda[1-9]
    mkdir /mnt/usb
    mkdir /mnt/sdcard
    mount -t vfat /dev/sda1 /mnt/usb
    mount -t vfat /dev/mmcblkp1 /mnt/sdcard
    finally you can use your usb/sd in wiscore

  • @wentao also not working..lsusb cannot fix problem..alt text

    ls usb problem ..
    alt text

  • Hi erickfloors:
    Now I will give you configure files and image with usb functin, you can download them and test

    Our image :

    Then build as follows In the WisCore-SDK by yourself:

    1. download config files


    2. Replace the old config
         cp .config products/wisAvs/opwrt-wisavs-topv002-1-20170519.config
         cp config-3.18 products/wisAvs/target/linux/ramips/mt7628/config-3.18
    3. re-build workspace
         refer to github:
         or use command directly:
         ./build/ wisCore hgw
    Finally burn the image and use it

  • @wentao Unfortunately your bin image does not support the official repo of kernel .23 so i can not install the package i want .. and i try to redevelop it by changing the config and unfortunately wiscore is not detected in dhcp leases and wifi is not detected if i scan with wiscore app Alexa..before replacing the config that you give is normal just still problematic in lsusb and mmc reader

  • @erickfloors update case..
    wiscore need several time reboot, wifi scan fix on wiscore app..but sdcard have issue/bug detect mmc reader

  • @erickfloors
    The kernel we used is 3.18,can't support 3.23, and you said there are many problems, but I tested our image, it's ok, alexa, app, wifi usb and so on, except the sdcard, so I want to know what image you used, it's provided by us or built by yourself ?

  • @wentao update case..
    your image all problem fixed except mmc support is big issue..
    wiscore need several times reboot..
    if you want to try pulpstone custom firmware is powerfull..all modem usb package, usb fixed, openvpn, repo official support with opkg install package..

  • @wentao said in lsusb bug with rc342 wiscore firmware (lsusb Bug Report ):

    The kernel we used is 3.18,can't support 3.23, and you said there are many problems, but I tested our image, it's ok, alexa, app, wifi usb and so on, except the sdcard, so I want to know what image you used, it's provided by us or built by yourself ?

    all fixed problem..need several time reboot
    alt text
    big issue mmc reader
    alt text
    lsusb fixed all running well

  • @erickfloors
    About the sdcard, we will check and solve it as soon as possible.
    But you said the wiscore need several times reboot, I didn't find, so please tell me more details about this, which parts need reboot? what's the message?
    And the official package, our kernel is 3.18.45, it's not support opkg install

  • @erickfloors
    We add the sdcard function now, but there two bugs:

    1. it's not support hot plug, it will crash the kernel, so you should plugin sdcard before power on

    2. sdcard and LAN port are in conflict, you can change sd driver to use LAN port

       vi build_dir/target-mipsel_24kec+dsp_uClibc- +3021
       change "reg |= 0x1e << 16"  to "reg |= 0x18 << 16"

    you can download firmware and config file in github:

  • @wentao several time reboot need firsrt time only..and next running is fine..
    several time reboot need for detection dhcp list on dhcp server router..

  • @wentao Your statement about sdcard plugin before power on that is not work for me .. all the way I have tried several times but sdcard still not detected
    As a note I use this firmware to try it

    Like what do you mean how sdcard plugin before power on
    alt text

    Unfortunately I was forced to use a usb hub with mmc reader to use sdcard for ntfs storage

Log in to reply

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.