SubBand selection command missing in RAK811



  • Multitech LoRa Conduit can only listen to 1/8 of the spectrum at a time, they call it SubBand and each is numerated 1-8. A command to limit the frequencies (or select the subBand) in which the at+join=otaa or at+send commands are transmitted is missing.



  • Hi FerCossio

    What's the soft version of your RAK811?
    Yes, Multitech LoRa Conduit can only listen 8 channels.
    because our module US915 support 72 channels , if your gateway not support all the channels , you should use set_config ch_list to enable the gateway support channels for example 0-7 channel. others should be closed

    for example:

    at+set_config=ch_list:7,off
    or
    at+set_config=ch_list:7,on,0,3

    and check
    at+get_config=ch_list

    Default, US915 up channel 0-63 902.3Mhz-914.9 0.2M step
    64-71 903.0MHz-914.2 1.6Mstep



  • This post is deleted!


  • I have tested the commands in ver. 1.0.3.5
    command:
    at+get_config=ch_list
    answer:
    3,off;4,off;5,off;6,off;7,off;8,off;9,off;10,off;11,off;12,off;13,off;14,off;15,off
    command:
    at+set_config=ch_list:7,on,0,3
    answer:
    ERROR-1

    at+set_config=ch_list:<any number>, on, 0,3 always fails



  • Hi FerCossio

    Your current use the version is the actility certificate 868M Firmware .

    Please test the attachment latest 915M Firmware.

    0_1490236399846_RAK811_V1023_RELEASE_915.bin

    Thanks



  • I'm receiving the same errror (ERROR-1) when trying to change the ch_list.
    Firmware is RAK811_V1023_RELEASE_868.bin

    What to do?



  • 868 Band need the customer frequency .
    at+set_config=ch_list:3,on,866200000,0,5

    Thanks



  • @junhua How do the overlapping freq. work (903MHz-914.2MHz)?
    In example: what happens when I turn up channels 4, 5, 6, 7, 8, 9, 10 but turn off channel 64?



  • @FerCossio Here seems no overlapping frequency , channels 4 -10 (903.1-904.3)with bandwith 125KHz datatate range dr0-3, channel 64 (903.0) with bandwith 500KHz,datarate fix dr4.



  • Please provide example to turn off all channels except 868,1 MHz.
    Thanks, Peter



  • @alviso you change the default channel ,shoud upgrade to new firmwave version V1026 .please see the examples
    at+get_config=ch_list
    at+set_config=ch_list:0,on,868100000,0,5
    at+set_config=ch_list:1,off
    .
    .
    .
    at+set_config=ch_list:15,off

    http://www.rakwireless.com/en/download/RAK811 LoRa Module/Firmware upgrade

    http://docs.rakwireless.com/en/RAK811 LoRa Module/Software Development/RAK811 LoRa AT Command V1.3.pdf

    Thanks



  • I have configured my rak811 (RAK811_V1026_RELEASE_868.bin) to enable only channel 0 with frequency 868100000 and SF9 using

    at+set_config=ch_list:0,on,868100000,3,3

    but when I send a message it seems to use any available band (868.5, 867.3, 868.3...).

    I wanto to send all the messages in the 868.1 frequency because I am using a single channel gateway listening only to that frequency. How can I do it?



  • Ok, I think I have found a partial solution.

    I have configured all the channels as:

    at+set_config=ch_list:0,on,868100000,3,3
    at+set_config=ch_list:1,on,868100000,3,3
    at+set_config=ch_list:2,on,868100000,3,3
    ...
    at+set_config=ch_list:15,on,868100000,3,3

    And now all the messages are sent in the 868.1 frequency



  • I think there is some problem with the rak811 firmware.
    As you can see in the following image, only one of every two messages is really sent in the 868.1 freq; in other words, one message is sent properly, but the following message is always sent a bit drifted.
    alt text


Log in to reply
 

Looks like your connection to RAK Support Center was lost, please wait while we try to reconnect.